jdk8 Lambdas表达式使用工具错误

错误列表

错误提示:

代码编写阶段提示错误:usage of api documented as @since 1.8+

解决办法:

File >> Project Structure >> Project Settings >> 项目 >> Modules >> Sources >> Language Level

选择:8 – Lambdas,type annotations etc.

 

 

 

错误提示:

maven打包的时候提示错误: -source 1.7 中不支持 lambda 表达式

解决办法:

在项目的pom.xml文件中修改配置的jdk版本

 

 

 

错误提示:

build的时候提示错误:
Information:java: javacTask: 源发行版 1.8 需要目标发行版 1.8
Information:java: Errors occurred while compiling module ‘ssm’
Information:javac 1.8.0_65 was used to compile java sources
Information:2017/9/27 11:05 – Compilation completed with 1 error and 0 warnings in 1s 715ms
Error:java: Compilation failed: internal java compiler error

解决办法:

右键项目 >> maven >> Reimport


guolin

guolin

相信世界,向往美好,记录成长过程,分享个人心得,充实平凡生活。 网站信条:因为喜欢,所以热爱。

1 条评论

guolin

guolin · 2018年3月7日 下午1:28

开发工具为:Intellij idea

发表评论

电子邮件地址不会被公开。 必填项已用*标注